VNC 2019

* indicates required